Skip to main content

Hi I have had this system for just under a year and very happy with it - However, on Sunday just passed, the manager of the venue turned systems on and suddenly the interface was no longer working -

I checked our online account and saw that the unit had been updated automatically when it was turned on, and now, no longer is accessible -

Trying both a PC and MAC - it is not seen as a USB device - MYDMX wont recognise it - and it shows up on the desk top as CRP DISABLD

It would appear that the firmware updateDMX_MAC 2 corrupted the device - does anyone know how to fix this?

Like many people here - we are a venue and need our lights working every night - it's crazy that a software update that we didn't even initialise can kill the unit

Thanks in advance


Images (1)
  • DMX_MAC 2
Original Post

Hi, any firmware update must be done manually through hardware manager and they are always optional, unless really old. Perhaps someone did something they weren't too sure of, and even then it is rare for firmware upgrade to brick anything.
Have you tried using Hardware manager to see if it detects or tried a different USB port or different USB cable?

Add Reply

Link copied to your clipboard.