Skip to main content

I purchased the mydmx 2.0 yesterday. Didn't work. Downloaded the latest beta here, now I can launch the software yet it only goes into demo mode because it can't detect any USB or ethernet controllers.

The USB is recognized in the hardware profiler (osx 10.8) and is plugged in via usb and the lights are on.

Any help?
Original Post

Replies sorted oldest to newest

OK, removed everything (dragged to trash) did a fresh download.
Had the unit plugged in with 1 addressed device connected.
Ran the installer, setup screen opens with no change, still no device detected.

Shows up in the system profiler though as

Intelligent USB DMX interface SIUDI9C
Version 1.11
MyDMX 2.0 software doesn't recognize my MyDMX USB controller. I tried on a Mac with your beta version released on Dec 4 and your stable version released on August 28. I also tried it on a WinXP machine with your stable version released on August 28. I know the controller isn't defective because it still works with MyDMX 1.0. Any suggestions?

Add Reply

Link copied to your clipboard.