Skip to main content

Help, I think I have a little problem with one of my PS2's....Well apparently on one of them, when I am on digital Scratch mode when I try to toggle, when I touch the wheel it automatically suppose to go back to the saved cue point automatically, but it doesn't do it works sometimes, but sometimes there is a like 2 or 3 second pause before it starts up....could it be the paremeter settings??? I tried to change them, but the ratio and timing always goes to 0008 but I want it on zero, but it always goes there!!! I need some help guys.....Thanks!!!!!
Original Post

Replies sorted oldest to newest

If the PS2's are anything like AA's other players, you will have to enguage the "Hold" feature in order for your perameters to stick when you change them. Otherwise they are momentary.

As far as the spuratic scratch features, have you tried just using the realtime scratch, instead of holding the scratch button down (again, i dont own a PS2, but i can imagine how it works) Just tap it (once), and see if the scratch is straight realtime again. If it is, and its probably working properly, then i would imagine its just your settings. Try turning the PSP to a lower setting, and see if the Beat Juggle scratch mode is working.
Originally posted by tigrsharc1:
[qb] Hypnotiq have you tried resetting your players? Reset your players, also make sure you cue the spot you want to juggle right at the spot you want. See if that helps get you back on track. Cool [/qb]
This may sound like a stupid question but how do you restart your players??????
Originally posted by Billabong:
[qb] 1. Power off players
2. Twist "Search" knob counter-clockwise and hold it.
3. Turn player on while holding knob counter-clockwise. You should see the display flash 3 times if you did it correctly. [/qb]
Wow I was having a major issue with my Velocity's. I even emailed American DJ with my problem...
here' the email
Hi I have a problem with my Velocity. The left CD player plays and works fine but the right one does not play any CD's. I attempt to play one but when I hit play it sounds like "s****ing metal" also sometime it sounds like a tone (a bleep). Also when I hit the play button the numbers on the display jumps around. This problem first happened Friday night at a gig, I had to turn the power off to the CD players and turn it back on to reset the problem. It worked fine the rest of the night but today I turned it on and tried it and it will not work at all. Please contact me so that I can get this problem fixed. My Velocity's are my only DJ CD players so I need this problem corrected ASAP. I really don't want to resort to taking crates and crates of vinyl to my gigs again.

I tried what Billabong suggested and sure enough it fixed the problem. But does anyone know what could be causing the problem? I'd hate for this to happen live during a gig again even though I do have my laptop there as backup.

Add Reply

Link copied to your clipboard.