Skip to main content

Hi, I have just received my new MyDMX 5 unit that I ordered and I cannot get it to work no matter what I try. I have a single light bar hooked up to it that starts at DMX address 1. I am using Port 3 to send Universe 1. I have tried on both a Windows and a Mac laptop using the latest software downloaded from the web site, I have tried different USB and DMX cables, and I have tried both ports 3 and 4. The software recognizes that the controller is active and the controller says PC when running the software, but I can never get it to send a signal to the lights. The DMX light on the front of the controller is quickly flashing red whether I have the software running or not. What does that mean? Am I doing something obviously wrong? HELP!!!

Original Post

Replies sorted oldest to newest

I have downloaded the Windows version and get the following error when I try to install it:

This is in the installation log:

************************************* Invoked: Tue May 14 12:15:59 2024
[0] Arguments: C:\Users\****\Downloads\myDMX 5 V5.0.4.2 for PC.exe
[6] Operations sanity check succeeded.
[12] Using metadata cache from "C:/Users/galucket/AppData/Local/cache\\qt-installer-framework\\3db580f7-4072-30bf-b4e1-3b805679ab16"
[12] Found 0 cached items.
[12] Language: en-US
[643] mydmx 5 v5.0.4.2 for pc
[643] Daslight5
[643] mydmx 5 v5.0.4.2 for pc
[643] myDMX5
[643] mydmx 5 v5.0.4.2 for pc
[643] CameoD5
[643] : Error : Invalid name of file!
Please do not rename.

I have not tried the Mac version yet.



Images (1)
  • mceclip0

Unfortunately, I still have problems with the Windows version running on Windows 11. While the software installed correctly, I still have issues. When the controller is hooked to my Windows machine with the software running, all the light does is strobes a white color intermittently. I also cannot get Hardware Manager to run on Windows, either starting it via the tools menu or running the standalone executable. It simply does nothing when you try to run it.

The Mac version is now working as expected, so I guess I will stick with that one for now.

Yes I updated the firmware with the new releases hardware manager on my Mac - again, I cannot get hardware manager to work at all on my PC. I tried both ports 3 and 4 since I only have 3-pin DMX cables and those are the two 3-pin ports. I have a very simple setup too. A single Eliminator Lighting Mega Bar RGB EP in 34 channel mode. Starting DMX address of 1. Still the same problem using either port.

Add Reply

Link copied to your clipboard.