Skip to main content

Setup - fixture drops into Patch panel at address desired, no show in faders panel. Cant move it or add another fixture - add just replaces the previous selection. #$@% ???

Faders do not send on theri channels, i assumed they would send data 0-255 even without a fixture defined but won't control the lights that are on those channels.

Worked Yesterday but for one ficture was dead and CHavuet splash jr's seemed to be ff by one address.
Original Post

Replies sorted oldest to newest

Where to begin.

I had a case where(OK, 2 cases) where MyDMX took a poop on me at a show. The first time, I had no time, went into fail-over mode and used my DMX Operator. The second show(same band, same venue, same computer, same everything) and I quit MyDMX, re-plugged the dongle, re-started MyDMX, and I was happy.

First, I'd check the physical(cabling) and ensure all are DMX cables(best results) and yu have total end to end connectivity. Stringing them all together and then running a cable tester works great for this quick test.

Check your addresses as well.

Is this a fresh MyDMX install? As in perhaps from the web site, dated June 5, 2008(when you see it load).

If time permits, set up a new universe? Sometimes it's best to start fresh.

I can't even relate to these problems. When MyDMX was crapping out on me, it would go into mega super slow-mo mode, IN addition to NOT sending data. I'd typically test this by running MyDMX with the dongle plugged in, and hitting "W" for my "all white" scene. If it is complete within 2 seconds(regardless if lights are attached), then I know MyDMX is working fine. When I have the problem, it can take up to 5 minutes for it to do the same thing on the screen.

You are right, a fader should still send data on the channel with the values of 0-255. The advantage of having a "fixture" installed or associated with those channels is that you get the benefit of the profile to help you make changes more intelligently on the fly.
Jingles : I'm using the myDMX USB controller. All LED's steady on. MyDMX, Setup tab selected, Status line displays "USB mode:1 SIUDI 6C VER:2.00 ...".

Thanks for the Welcome.


Notice: My usernamesake, the planet Mercury, ends it's Retrograde (Rx) motion today and turns Direct. Communications and short term/short notice Travel problems begin to straighten out, the pace of life increases and roadblocks and obstacles seem to fall away. Gods' Speed!
Try uninstalling and reinstalling from the website. the June 5th version Chris was talking about is our best one out yet. give that a try if it doesn't work please let me know. Also i believe if their is no profile on a channel it wil not allow output to that channel through the dongle. if any thing place a generic dimmer profile there and it should work.
Chris : Cabling known good - DMX Data cables and Permanent Marker 'branded'.

2 x ADJ Par36LED [6 ch.] co-resident @ addr 10 (dip 4 & 2 on)
2 x Chauvet LED-Par83 (COLORsplash JR.) [4 ch.] co-resident @ addr 16 (dip 5 on [& 10 for DMX Mode])

June 5, 2008 install (disc in box) and already downloaded and installed from ADJ web which reports June 5, 2008 date as well.

(BTW, many times when a program suddenly goes 'slo-mo' on you it's Windows swapping memory in and out when you try to switch focus to another task. Programs loose track of the resources they allocated and memory 'leaks' away until suddenly, 'chug.chug.chug. Web page Video Players (YouTube f.i.) seem particularly adept at using up memory. Rebooting is then prescribed)

Jingles : As you see I already went to the web for the latest software to no avail. Exited. Unplugged the myDMX Controller, count 5, replugged, Now I can assign multiple fixtures - just drag and drop! Unfortunately the faders (now 'intelligent') don't affect the lights at all, which are all dark now.

Device Manager reports "Intelligent Usb Dmx Interface (low cost U6)".

Then I check the status and sure enough, myDMX is in Demo Mode so it doesn't see the interface.

I wanted to write this before rebooting so that's the next step.

Rebooted. Back to first base. DMX Mode but fixture drops into Patch panel at desired address and that's all. Can't move it. Pick another fixture and prev disappears. Cursor will only drag a box around clicked point, curious that.

User options menu is grayed out I just noticed - I'll do a search on that in the forum. So now I know my failMODE profile...

EUREKA! Tried restarting the controller after rebooting - exited MyDMX and reset the interface and now I can assign fixtures and they work great... (Thanks)
...except for the Chauvet COLORsplash JR./LED-PAR83 fixtures residing at address one greater than the dip settings. I have them set to channel 16 (dip 5 on [& 10 on for DMX mode]) and they respond starting at channel 17. I think this problem deserves it's own thread - I'll start one.
AND... The ADJ P36LED profile needs work, some ranges are off or missing - sounds like my first intro to profile development!

Also someone added the Chauvet COLORsplash JR./LED-PAR83 to the American DJ list as an led-par83 fixture - that's just making the list longer than it has to be but it's official and might be in use in the field so..., sigh. At least I can delete it from my list for awhile.

if you wish to re arrange profiles you can go into c:drive>my dmx> scanlibrary> folder of your choosing. you can even create a folder on your own label it "My Rig" and move all the profiles you need too to that folder and once you load up the software all you have to do is go to that one folder and then there is all your profiles you need. no more needing to hunt them down. the problems you are having i dont believe i have heard of these before. i will let our product specialist and developers know about this. give me the specs on your computer. how many lights total? Thanks. the more info you have the more it will help. you can email me at james k AT American DJ DOT COM wit hthe spec list. Sincerely,
(BTW, many times when a program suddenly goes 'slo-mo' on you it's Windows swapping memory in and out when you try to switch focus to another task. Programs loose track of the resources they allocated and memory 'leaks' away until suddenly, 'chug.chug.chug. Web page Video Players (YouTube f.i.) seem particularly adept at using up memory. Rebooting is then prescribed)

Nope, ain't a memory leak issue. It's a MyDMX Bug. I'm not task swapping. I'm staying in MyDMX. I mean, how am I gonna get online in a venue that is a "vacuum" with no wired or wireless internet access, no access points? I just turn off my network interfaces, quit any unnecessary services, and then I'm good to go.

Quitting MyDMX, unplugging the dongle, re-plugging in the Dongle, re-launching MyDMX clears the problem 9 out of 10 times. It seems to me the USB driver needs a bit more TLC or retooling. This is reminding me of DigiDesign, where they design their SW so tight, you do updates and you could be hosed for a while. Or, you have to wait for Digi, and you're hosed because you can't get updates you might otherwise need..... At least MyDMX ain't that bad.

I find my best results come from waiting for the machine to boot, then plug in the dongle. Wait for happy tones, then launch MyDMX. I mainly get the quirk when starting from a cold boot and pre-plugging in the dongle before even starting, or at least before XP fully loads.

I'm covered. I have this MacBook pro and ProTools MPowered running on both Mac and PC.If one stops working, the other will keep me going.(I use external Mac-formatted drives with MacDrive installed)

Also, back to your issue of addressing:
Check DIP position 1. I bet it's ON and that's what's bumping your addresses up 1 address! OR, whatever DIP corresponds to 1. Of course, if you're starting with odd addresses, you know that's going to be on anyways. Just double and triple check those DIP switch settings. Those always kick my butt!
gJingles : Oh you just made my life way easier! Hadn't grokked that I could create my own Brand folder with a collection of just the fixture profiles I use copied into it. Thanks.

I'll email you requested info.

Chris : The problem where a normally 2 sec. op takes 5 min. could be myDMX mem leak. If it never happens until thre program's been used a while and if the hard drive activity lit is blazing away (Windows swapping back and forth to disk), it's 'Thrashin'. Whatever's going on, you seem to have identified the culprit rightly, the MyDMX program.

And I should point out (for anyone searching for the solution) the fix for the problem that this thread is about is the one you've proved helps the problem you just mentioned.
Quitting MyDMX, unplugging the dongle, re-plugging in the Dongle, re-launching MyDMX clears the problem 9 out of 10 times.

Plug the myDMX controller in after (re)booting and before launching myDMX.

Also, set splashjr's to address 17 (dips 5 & 1 on) just to make sure I didn't have dip 1 on previously or a bad dip 1 switch.
IN my scenario:

MacBook Pro had been on a while(say, at last 15 minutes). Clean boot, no other applications running, but my typical services running. No biggie.

Launch MyDMX, and IMMEDIATELY, I'm in massive slow-mo mode. Windows shows no abnormal activity. Not saying there is or isn't a leak, but it's acting more driver/hardware wonkiness. Since XP doesn't really support protected memory, a leak condition should often burn resources away.

But, the main thing is I know how to deal with it.

Add Reply

Link copied to your clipboard.