Skip to main content

Hi, I recently purchased the MyDMX Go, I have downloaded the firmware from ADJ but the firmware won't download and when I click on the wifi I get an error message XHL 12 (unable to scan Wifi). It then asks me to factory reset the device but it won't even do that.

I have also tried the firmware update but that shows error XHL 17

The device won't show its own wifi

I have looked at so many videos and forums and tried so many things but nothing seems to work.

Any help would be so appreciated.

Original Post

Replies sorted oldest to newest

Hi, XHL 17 means it timed out trying to do something.
Try bootloader mode, plug the USB end into the computer, but not the GO hardware, then open hardware manager, and once its open press and hold down the "D" button on the GO hardware while you plug it into the USB-C side of the cable, and hold it down for a few sends and it should boot up in "_BL mode" and from there you can try a factory restore.
Let me know how it goes.

@Jingles8302 I have updated the firmware i am on version 1.10 but the WiFi is not connecting. When I try to do a factory reset I get error message and when I trying your suggestion above and opened in bootloader mode and hit the factory reset it immediately disconnects. I am trying to restore wifi settings now. It timed out on the factory reset, and there is not a firmware version for WiFi. I had it for a short time but it was a version back in 2020. Now it is gone. I will try a factory reset again.

Last edited by Mike Siomacco

Add Reply

Link copied to your clipboard.