10.5.8

We no longer support 10.6.8 and I think that was a minimum OS version we supported back when it was supported.
I can send you a really old Mac version but it'll be old and buggy. But if you really want to try the oldest one I have. I'll send it to you.
Let me know.

Add Reply

Likes (0)
×
×
×
×